Active SMART Monitor overview

What is Active SMART Monitor and what can it do

Active SMART Monitor utility for controlling the health status of your hard disks. Active SMART Monitor can discover a probable hard disk drive (HDD) fail BEFORE it actually occurs. In regular usage, Active SMART Monitor can calculate the nearest possible date of hard disk fail.

How does it work? Active SMART Monitor uses S.M.A.R.T. technology, included in all modern hard disks. S.M.A.R.T. is an HDD self-testing and monitoring technology described in detail here. Simplified, it looks like the HDD is continuously making self-tests and calculating some “attributes”, which reflect the current state of efficiency and status of the HDD. Each attribute means some detail in HDD status – total hours of work, count of read errors, and others. If after a self-test, the HDD "thinks" that its state is changed, it changes the value of the corresponding attribute. For example, if the time of spin-up from idle state changed, the HDD would change (lower) the value of the "Spin-Up Time" attribute. Each attribute has a threshold (lower) value and, at achievement, the HDD may stop working.

Active SMART Monitor monitors attribute changes, analyzes speed of falling (lowering), and calculates remaining time of life HDD based on this data.

Furthermore, Active SMART Monitor shows other useful information about your HDD - supported standards, speed modes of operation, current mode of operation (PIO, DMA, UDMA&ldots;), and others. Detailed info about these modes can be found under "HDD technology".

About Active SMART Monitor...

Overview
Installation

User interface

Main window
General tab
Extended Info tab
S.M.A.R.T. tab
Preferences tab
Log tab
About tab

Registration and License

license
unregistered copy limitation
registration and ordering

Support

support

Aleksey S Cherkasskiy
alexey@panterasoft.com
Copyright (c) PANTERASoft 1999-2002


Active SMART Monitor overview

Active SMART Monitor utility for controlling the health status of your hard disks. Active SMART Monitor can discover a probable hard disk drive (HDD) fail BEFORE it actually occurs. In regular usage, Active SMART Monitor can calculate the nearest possible date of hard disk fail.

How does it work? Active SMART Monitor uses S.M.A.R.T. technology, included in all modern hard disks. S.M.A.R.T. is an HDD self-testing and monitoring technology described in detail here. Simplified, it looks like the HDD is continuously making self-tests and calculating some “attributes”, which reflect the current state of efficiency and status of the HDD. Each attribute means some detail in HDD status – total hours of work, count of read errors, and others. If after a self-test, the HDD "thinks" that its state is changed, it changes the value of the corresponding attribute. For example, if the time of spin-up from idle state changed, the HDD would change (lower) the value of the "Spin-Up Time" attribute. Each attribute has a threshold (lower) value and, at achievement, the HDD may stop working.

Active SMART Monitor monitors attribute changes, analyzes speed of falling (lowering), and calculates remaining time of life HDD based on this data.

Furthermore, Active SMART Monitor shows other useful information about your HDD - supported standards, speed modes of operation, current mode of operation (PIO, DMA, UDMA&ldots;), and others. Detailed info about these modes can be found under "HDD technology".


Installation

Active SMART Monitor requires certain system drivers to be installed to function correctly. Windows 95/98/ME requires that SMARTVSD.VXD be installed and registered. This can be accomplished by allowing the installer to do it automatically by choosing typical setup. You can also copy the SMARTVSD.VXD file from the Windows 95/98 CD Rom to the Windows\System\Iosubsys directory. You will have to reboot the system.

When Active SMART Monitor is to be used to monitor SCSI drives or RAID arrays, the WINASPI driver must be loaded and started on both Windows 95/98/ME and Windows NT machines. The ASPI driver handles communications between the SCSI controller and the system. The driver is NOT normally required for Hard Disk Drives to function if no other SCSI devices are present. If the WINASPI Driver is not installed Active SMART will not be able to monitor the S.M.A.R.T. Alerts issued by the drive, nor will drive information be displayed. All other functions of Active SMART are not affected. You can download WinASPI driver from Adaptec website: http://www.adaptec.com


Main window

The main window consist of two main parts:
- disks list (on top)
- information area

The disks list gives information about all of the disk drives in the system.

The information area (below the HDD list) consist of 6 tabs:


General tab

General tab contains common (general) information about chosen HDD.

HDD information

- | Drive manufacturer
- | HDD model
- | Drive capacity
- | Serial number
- | Firmware revision number
- | Current Ultra DMA mode number (if supported)
- | S.M.A.R.T. compatibility
- | Drive's location in your system
- | Nearest T.E.C. date

Disk manufacturer

- | Disk manufacturer logo

Monitoring

- | Start date
- | Last check date
- | Nearest T.E.C. date


Extended Info tab

This tab contains information about volumes on your HDD.

Volumes

- | List box, containing all volumes, presented on all drives in the system
- | File system name
- | Total space for selected volume
- | Free space for selected volume
- | Disk space usage section shows usage of the disk space for the selected volume (graphical and percentage).

Logical Info

- | Cylinders number
- | Heads number
- | Number of sectors per track
- | Number of total addressable sectors


S.M.A.R.T. tab

S.M.A.R.T. details tab shows all available information about S.M.A.R.T. attributes of the chosen HDD.

It contains:

- | ID - attribute's ID number
- | Attribute - attribute description (short text description of attribute).
- | T.E.C. date - Threshold Exceeds Condition - supposed date when this attribute achieves threshold value, in other words probable date of end of HDD life. Prognosis of this date based on the factor "Speed of attribute change" (described above), so don't be surprised at variations of T.E.C. date, especially immediately after S.M.A.R.T. attribute change.
- | Value - current value of S.M.A.R.T. attribute
- | Threshold - threshold (critical) value of attribute - value, which disk manufacturer means as critical - an achievement of this value means that HDD fail is very probable.
- | Wrost - worst attribute value - worst ever (lowest) value of this attribute during all life of this HDD. Use it only for information.
- | Changes - attribute value on the start monitoring


Preferences tab

Preferences Info tab

Options tab allows you to set up Active SMART Monitor. Settings on this tab:

S.M.A.R.T. poll period : N hours N minutes
Interval of HDD S.M.A.R.T. info polling - how often Active SMART Monitor will poll your HDD's for changes in S.M.A.R.T. attributes if working in the background.

Enable monitoring at Windows startup
If you check this option Active SMART Monitor will be automatically loaded every time Windows starts.

Check at startup and exit
Active SMART Monitor will check your HDD's only at system startup. If there is no change in attribute values, Active SMART Monitor finishes. If any attribute is changed, Active SMART Monitor displays a message box and asks do you want to see the info about this HDD.

Show alert message
When S.M.A.R.T. attribute changes or T.E.C. occurs the alert message will be shows if this box is checked.

Send e-mail report to
Enter e-mail to which Active SMART Monitor sends reports. You should not see any message boxes in this case. Warning! Active SMART Monitor uses your default mail client to send e-mails! So check e-mail settings to make sure it will work properly!

Send a network message to
Also Active SMART Monitor can send messages via local network (like 'net send' command on Windows NT system.) This feature is very important to Administrators of networks. Message can be send to a specified recipient in the event of a S.M.A.R.T. alert.

Play the sound
Plays the specified sound file (.wav) when attributes is changed or T.E.C. detected.


Log tab

The Log tab contains information such as the time Active SMART Monitor was started, and all alerts reported. Once an alert is occured, Active SMART Monitor logs the event date and time, the HDD model, capacity and serial number. The disk quota alerts are also recorded in the log along with all remote messaging notifications and failures.


About tab

This tab shows information about current program version, build number, copyright information, contact and registration links. Use these links to visit our website and download program updates and our other software products.


S.M.A.R.T. overview

Self Monitoring And Reporting Technology (S.M.A.R.T.) is a major step to the truly fault tolerant computing environment. As all of us know that the Hard Disk Drive's, (HDD) in our servers, workstations or even home computers hold vast amounts of critical data. The HDD also has the greatest potential for failure of any component in a system. To date we could check a system for “soft errors” like cross linked files or lost clusters, we could scan for viruses and check the surface of the drives platters for defects, but there was really no reliable way to detect hardware failure.

Of course after the fact there are some diagnostics to check the drive out, but alas, our precious data is gone. S.M.A.R.T. on the other hand, monitors the drive's hardware performance with drive specific tests on the controller. When a fault is detected, a notification is given that the hardware may fail and all data should be backed up immediately and the drive sent for repair or replacement.

S.M.A.R.T. compliant drives are the norm, and have been shipping for several years now, and almost all drives available today are S.M.A.R.T. compliant. S.M.A.R.T. is defined and endorsed by the Small Form Factor (SFF) Committee, which includes Compaq Computer Corporation, Hitachi, Ltd., IBM Storage Products Company, Maxtor Corporation, Quantum Corporation, Seagate Technology, Toshiba Corporation and Western Digital Corporation among others. In fact, IBM has shipped nearly 3 million S.M.A.R.T. compliant drives, which have logged over 20 billion hours. S.M.A.R.T. is an industry standard reliability prediction indicator for both IDE/ATA and SCSI HDD.


Basics of S.M.A.R.T.

S.M.A.R.T. is actually a failure predication method based on a device varying from a defined set of thresholds. The idea is an industry wide continuation of PFA (predictive failure analysis) implemented and invented by IBM for its mainframe computers. The first company to implement S.M.A.R.T. technology on desktop PC's was Compaq Computer with their DFP (drive failure prediction).

A drive that is S.M.A.R.T. compliant has a series of tests embedded on the controller of the HDD. The data is constantly collected and monitored for variations within vendor specific thresholds. These tests are designed to predict the impending degradation or failure of a drive. For instance, if a drive is designed to spin at 3500 RPM and the manufactures threshold is +/- 100 RPM, the drive may be within threshold for a year, but as the drive ages the RPM's begin to fluctuate and before long are at 3300 RPM. Once that happens, an error is logged and a message is sent to the System Administrator and/or the user. The drive can now be scheduled for replacement before the condition gets worse and becomes catastrophic.

The various tests and thresholds that govern pass or fail are vendor specific and usually proprietary. The type of failures monitored by SMART include head and servo issues which result in read and seek errors, motor failure or bearing problems that result in spin up problems, excessive bad sectors and thermal testing. The faults are categorized into predictable and unpredictable, with the unpredictable usually being catastrophic. Unpredictable faults are normally electronics related or caused by static electricity or from handling. Testing and data collection can be in an on-line or off-line mode.

In the on-line mode, data is collected during idle times.

In the off-line mode the drive is required to respond to commands directly from the host and interrupt any operations.

Active SMART Monitor has automatic settings for monitoring the drive in on-line status as well as test now button for immediate off-line testing and data collection where supported. In order to make the implementation of S.M.A.R.T. practical, the system has to be able to alert the user, or in the case of a network, the system administrator of a potential failure.

To date the only way to utilize the S.M.A.R.T. technology is through the newer BIOS or with a simple desktop application that notifies the user of a failure. Most of these utilities are manufacturer specific and run under DOS. We go a step further. Active SMART Monitor runs natively under Windows 95/98/ME/NT/2000/XP and has easy to use messaging options where notifications can be sent via e-mail, network.

Active SMART Monitor also monitors more than two physical drives, and in fact can monitor all of the drives in your system.


License

The Active SMART Monitor is "try-before-you-buy" software. This means:

- PANTERASoft.Com exclusively owns all copyrights to Active SMART Monitor.

- Anyone may use this software during a test period of 30 days. Following this test period of 30 days or less, if you wish to continue to use Active SMART Monitor, you MUST register.

Unregistered use of Active SMART Monitor after the 30-day evaluation period is a violation of U.S. and international copyright laws.

- Once registered, the user is granted a non-exclusive license to use Active SMART Monitor on one computer (i.e. a single CPU), for any legal purpose, at a time. The registered Active SMART Monitor software may not be rented or leased but may be permanently transferred, if the person receiving it agrees to terms of this license. If the software is an update, the transfer must include the update and all previous versions.

- The Active SMART Monitor unregistered shareware version may be freely distributed, if the distribution package is not modified. No person or company may charge a fee for the distribution of Active SMART Monitor without written permission from the copyright holder.

- Active SMART Monitor IS DISTRIBUTED "AS IS". NO WARRANTY OF ANY KIND IS EXPRESSED OR IMPLIED. YOU USE AT YOUR OWN RISK. THE AUTHOR WILL NOT BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.

- You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset of the licensed program, except as provided for in this agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and/or civil prosecution.

PANTERASoft.Com reserves all rights not expressly granted here.

- Installing and using Active SMART Monitor signifies acceptance of these terms and conditions of the license.

- If you do not agree with the terms of this license you must remove Active SMART Monitor files from your storage devices and cease to use the product.

Copyright (c) PANTERASoft 2000-2001


Unregistered copy limitations

The unregistered version of Active SMART Monitor is fully functional. The 'save options' function disabled only. Anyone may use this software during a test period of 30 days. Following this test period of 30 days or less, if you wish to continue to use Active SMART Monitor, you MUST register.

You can free try program within 30 days trial period. Also, we can provide only limited support (and with low priority) to unregistered users.

When you'll register, you'll get the registration key (serial number) which will remove unregistered copy limitation. Your registration key will work for all future versions of Active SMART Monitor (or we may provide you with the new key, if the keys will be changed for some reason).

Copyright (c) PANTERASoft 2000-2001


how to register Active SMART Monitor

Registration

You can register your copy of Active SMART Monitor via RegNow! registration service using any major credit card. The registration fee is 24.95 US Dollars only! Volume discounts are available. You can register on-line, using fax, toll-free phone, by check or wire transfer. Money orders are also accepted.

Once the software is registered, the initial splash screen will not be displayed when the program starts.

Registering Active SMART Monitor will benefit you with:
- No more nag-screens
- No limitations on the 'save options' function
- Free future updates
- Free 24h technical e-mail support
- Higher priority when suggesting features.

You can go directly to the secure order page:
https://www.regnow.com/softsell/nph-softsell.cgi?item=3560-8

If you don't have convenient Web access, the next best way to order Active SMART Monitor is by fax (also using the credit card) or phone (toll-free). In addition, you can send us the check (American Express Traveller's cheques and Eurocheques are preferred). The order form template, fax & phone numbers, and mailing address are in the file order.frm.

Be sure to give us the correct e-mail address when filling the order form; if you'll make a mistake when typing it, we'll be unable to send you your registration code.

On payment approval, we'll send you the registration key, which will remove the nag screen in Active SMART Monitor. Your registration will be valid for all future versions of Active SMART Monitor.

Copyright © PANTERASoft 2000-2001


Support

Before you contact us, please do the following:

- Be sure that you're doing everything right. We all make mistakes sometimes… Be attentive.

- Look at the Help file: it may already contain an answer to your question. A lot of people ask us something like "how do I…", though the complete information is there (in the document you're reading now).

- Visit Active SMART Monitor home page in the Internet at http://www.panterasoft.com. It's a good chance that you'll find the newer version of Active SMART Monitor there; we're trying to update the program once a month or even more frequently - when our staff is not on vacations, of course. Also, if the serious bug has been found in the program, but the new version is not ready yet, we make the hot fix for it.

- Visit our forum at http://www.panterasoft.com

But if you still have a problem with Active SMART Monitor and noting else helps, please contact technical support staff at:

support@panterasoft.com

Please inform us about the following:
- Active SMART Monitor version (from main window caption)
- Active SMART Monitor order ID (if you're a registered user) - this will help us to process your request faster
- where did you get Active SMART Monitor (http or ftp site)
- Windows 95/98/NT version (including service packs and other fixes installed), US or international, OEM or not
- computer information: CPU type and speed, amount of memory installed
- description of your problem (as much information as possible to retrieve the problem)

Also you can send the fax message to:
Fax number: 206-312-1590

In order to get the complete computer information (working under Windows 95), open the Control Panel, click on "System" applet and press "Print" on "Device Manager" tab.
We'll try to help you as fast as possible, usually in one or two business days.

If you have any comments or suggestions for the next releases, please feel free to post them to us.

Copyright (c) PANTERASoft 2000-2001